问题集锦

python正确查看pip版本支持

分享给大家,少让大家踩坑。

我是为了下载tensorflow才想查看版本支持,但是我查到pip在我电脑上支持得版本是:

[(‘cp37’, ‘cp37m’, ‘win_amd64’), (‘cp37’, ‘none’, ‘win_amd64’), (‘py3’, ‘none’, ‘win_amd64’), (‘cp37’, ‘none’, ‘any’), (‘cp3’, ‘none’, ‘any’), (‘py37’, ‘none’, ‘any’), (‘py3’, ‘none’, ‘any’), (‘py36’, ‘none’, ‘any’), (‘py35’, ‘none’, ‘any’), (‘py34’, ‘none’, ‘any’), (‘py33’, ‘none’, ‘any’), (‘py32’, ‘none’, ‘any’), (‘py31’, ‘none’, ‘any’), (‘py30’, ‘none’, ‘any’)]

但是清华镜像上的tensorflow不支持cp37的,所以没有下成功。等我下载好了,也会把tensorflow得安装过程说明。

首先,键盘按win+R,输入cmd打开DOS窗口,输入python,进入python环境。

1.32位:

import pip;
print(pip.pep425tags.get_supported())

2.64位:(这句我试了不好使)

import  pip._internal;
print(pip._internal.pep425tags.get_supported())

3.64位:(这句好使)

import pip._internal.pep425tags;
print(pip._internal.pep425tags.get_supported())

一条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注